CVE-2026-9697

undici vulnerable to TLS certificate validation bypass via dropped requestTls in SOCKS5 ProxyAgent

HIGH
7.4
CVSS Score
Published: June 17, 2026 at 04:46 PM UTC
Updated: September 10, 2026 at 01:20 PM UTC
7 products affected across 3 vendorsUndiciOpenShift AIOpenShift Pipelines

Using undici by undici?

Get instant alerts when new vulnerabilities affect undici - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.4
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Impact: undici's ProxyAgent silently drops the requestTls option when configured with a SOCKS5 proxy URI (socks5:// or socks://). The target HTTPS connection through the SOCKS5 tunnel falls back to Node's default trust store, ignoring user-configured ca, cert, key, rejectUnauthorized, and servername settings. Applications that pin to an internal or corporate CA via requestTls.ca will, when their proxy URI is SOCKS5, get the default Mozilla CA bundle as the trust anchor instead. Any cert signed by any publicly-trusted CA for the target hostname is accepted, breaking the intended pin and enabling MITM read and tamper of the HTTPS exchange. Affected applications are those that use undici's ProxyAgent (or Socks5ProxyAgent directly) with SOCKS5 AND rely on requestTls for TLS scope restriction. The bug was introduced in undici 7.23.0 when SOCKS5 support was added. Patches: Upgrade to undici v7.28.0 or v8.5.0. Workarounds: No workaround is available within the SOCKS5 path. If a SOCKS5 proxy with TLS scope restriction is required and an upgrade is not yet possible, route the traffic through an HTTP-proxy ProxyAgent instead, where requestTls is honored correctly.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.23.0 ≤ v < 7.28.08.0.0 ≤ v < 8.5.0
Affected range stops below 7.28.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.5.0, so it looks safe — our inference, not a vendor statement
60%
Vendor states this is fixed in 4 (unaffected)
Vendor states this is fixed in 4.2.0-13 (unaffected)
All versions
Vendor states this is fixed in 1787121387 (unaffected)
Vendor states this is fixed in 1787801527 (unaffected)
7.23.0 ≤ v < 7.28.08.0.0 ≤ v < 8.5.07.23.08.0.0
Vendor states this is fixed in 7.28.0 (unaffected)
Vendor states this is fixed in 8.5.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (25)

Vendor Advisory
Source: cverecord
https://cna.openjsf.org/security-advisories.html
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:22380
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:22934
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/errata/RHSA-2026:7378
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://access.redhat.com/security/cve/CVE-2026-9697
Source: 0b0ca135-0b70-47e7-9f44-1890c2a1c46c
https://bugzilla.redhat.com/show_bug.cgi?id=2490018

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.4HIGHopenjs
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-295

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card