CVE-2026-94276

Apache APISIX: Openid-connect introspection validation issue

MEDIUM
5.1
CVSS Score
Published: October 1, 2026 at 11:02 AM UTC
Updated: October 1, 2026 at 03:17 PM UTC
1 product affected across 1 vendorApisix

Using Apache APISIX by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache APISIX - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.1
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Improper Authentication vulnerability in Apache APISIX. On a route using openid-connect plugin with remote introspection against an authorization server that serves multiple issuers, a token that introspects as active for one issuer may get accepted on a route restricted to another. This issue affects Apache APISIX: from 3.12.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.12.0 ≤ v ≤ 3.18.03.12.0

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.1MEDIUMapache
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card