CVE-2026-94269

Apache APISIX: Servlet-style normalization creates a route/upstream authorization mismatch

MEDIUM
6.3
CVSS Score
Published: October 1, 2026 at 11:02 AM UTC
Updated: October 1, 2026 at 03:17 PM UTC
1 product affected across 1 vendorApisix

Using Apache APISIX by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache APISIX - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Use of Non-Canonical URL paths for authorization decisions vulnerability in Apache APISIX. In some configurations where a permissive route overlaps a protected one, a crafted encoded path can reach an upstream endpoint that the matched route's policies were never meant to cover. A request that should have been rejected is served instead, giving unauthenticated access to a protected upstream endpoint. This issue affects Apache APISIX: from 2.14.1 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.14.1 ≤ v ≤ 3.18.02.14.1

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMapache
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-647

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card