CVE-2026-94220

Apache APISIX: session fixation issue in feishu-auth and dingtalk-auth plugin

LOW
2.1
CVSS Score
Published: October 1, 2026 at 11:01 AM UTC
Updated: October 1, 2026 at 03:17 PM UTC
1 product affected across 1 vendorApisix

Using Apache APISIX by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache APISIX - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW2.1
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Cross-Site request forgery (CSRF) vulnerability in feishu-auth and dingtalk-auth plugins in Apache APISIX. An attacker who can get a user to click a crafted link may cause that user's browser session on a protected route to be established under the attacker's identity instead of their own. Any work the user then performs in that session, including uploads, form submissions, and account bindings, lands in the attacker's account. This issue affects Apache APISIX: from 3.17.0 through 3.18.0. Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.17.0 ≤ v ≤ 3.18.03.17.0

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

2.1LOWapache
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card