CVE-2026-93840

vLLM before 0.29.0 Cross-Request Logits Corruption via allowed_token_ids

MEDIUM
5.3
CVSS Score
Published: September 18, 2026 at 07:06 PM UTC
Updated: September 28, 2026 at 06:36 PM UTC
1 product affected across 1 vendorvLLM

Using vllm by vllm-project?

Get instant alerts when new vulnerabilities affect vllm - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

vLLM before 0.29.0 validates allowed_token_ids against tokenizer length instead of model output logits width in SamplingParams._validate_allowed_token_ids(). Attackers can supply token IDs above the output vocabulary that pass validation, causing LogitBiasState to corrupt GPU logits state and allow concurrent requests to sample tokens outside their allowlists.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.29.0
Vendor states this is fixed in 0.29.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-129

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card