CVE-2026-93587

ImageMagick before 7.1.2-31 Policy Bypass via PCD decoder

LOW
3.3
CVSS Score
Published: September 18, 2026 at 01:20 PM UTC
Updated: October 29, 2026 at 09:17 PM UTC
1 product affected across 1 vendorImageMagick

Using ImageMagick by ImageMagick?

Get instant alerts when new vulnerabilities affect ImageMagick - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.3
Exploit prediction
EPSS 0.1%
SSVC
No known exploit

Description

ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.9.13-567.0.0-0 ≤ v < 7.1.2-31
Vendor states this is fixed in 6.9.13-56 (unaffected)
Vendor states this is fixed in 7.1.2-31 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.3LOWVulnCheck
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusANALYZED
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card