CVE-2026-9312

Server-Side Request Forgery vulnerability in GitHub Enterprise Server allowed access to internal services via path traversal in upload endpoint

HIGH
8.2
CVSS Score
Published: May 27, 2026 at 12:02 AM UTC
Updated: July 23, 2026 at 07:32 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.2
Exploit prediction
EPSS 9%
SSVC
No known exploit

Description

A server-side request forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to send crafted requests to internal services by exploiting insufficient input validation in an upload endpoint. By injecting path traversal content into request parameters, an attacker could bypass the intended request flow and redirect internal API calls, potentially accessing internal services and exposing sensitive credentials. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.16.20, 3.17.17, 3.18.11, 3.19.8, 3.20.4, and 3.21.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.16.0 ≤ v ≤ 3.16.193.16.0 ≤ v < 3.16.193.17.0 ≤ v ≤ 3.17.163.17.0 ≤ v < 3.17.163.18.0 ≤ v ≤ 3.18.103.18.0 ≤ v < 3.18.103.19.0 ≤ v ≤ 3.19.73.19.0 ≤ v < 3.19.73.20.0 ≤ v ≤ 3.20.33.20.0 ≤ v < 3.20.33.21.0 ≤ v < 3.21.13.16.03.17.03.18.03.19.03.20.03.21.03.21.1 rc1
Affected range stops below 3.16.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card