CVE-2026-92596

Nodemailer before 9.1.0 Denial of Service via addressparser

HIGH
7.5
CVSS Score
Published: September 16, 2026 at 09:47 PM UTC
Updated: September 22, 2026 at 08:41 PM UTC
1 product affected across 1 vendorNodemailer

Using nodemailer by nodemailer?

Get instant alerts when new vulnerabilities affect nodemailer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.8%
SSVC
PoC

Description

Nodemailer before 9.1.0 contains a quadratic time complexity vulnerability in the addressparser component that allows remote attackers to cause denial of service by supplying a crafted comma-separated address list. Attackers can send a single email with a large number of addresses to block the Node.js event loop for extended periods, consuming 100% CPU and freezing the process.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 9.1.0
Vendor states this is fixed in 9.1.0 (unaffected)

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card