CVE-2026-91942

crawl4ai before 0.9.3 Cross-Site Scripting via innerHTML

MEDIUM
5.4
CVSS Score
Published: September 15, 2026 at 03:18 PM UTC
Updated: September 17, 2026 at 03:16 PM UTC
1 product affected across 1 vendorCrawl4AI

Using crawl4ai by unclecode?

Get instant alerts when new vulnerabilities affect crawl4ai - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.2%
SSVC
PoC

Description

crawl4ai before 0.9.3 contains a DOM-based cross-site scripting vulnerability in the Docker Playground UI that assigns untrusted crawl results to element.innerHTML. Attackers can craft malicious PDFs with event-handler markup to execute JavaScript in the Playground origin and steal API tokens from sessionStorage for authenticated API abuse.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.9.3
Vendor states this is fixed in 0.9.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.4MEDIUMVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card