CVE-2026-91935

Flowise before 3.1.4 SSRF and API Key Exfiltration via Chat Model Nodes

HIGH
8.3
CVSS Score
Published: September 15, 2026 at 03:17 PM UTC
Updated: September 20, 2026 at 01:16 AM UTC
1 product affected across 1 vendorFlowise

Using Flowise by FlowiseAI?

Get instant alerts when new vulnerabilities affect Flowise - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.3
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

Flowise before 3.1.4 fails to validate baseURL parameters in chat-model nodes, allowing authenticated users to redirect requests to arbitrary hosts. Attackers with chatflows:create or chatflows:update permissions can exfiltrate LLM provider API keys by redirecting requests to cloud metadata services or internal hosts.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.1.4
Vendor states this is fixed in 3.1.4 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.3HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
LOW
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card