CVE-2026-91860

Prototype Pollution in Vaadin Charts and Component Base via Unfiltered Deep Merge

MEDIUM
6.3
CVSS Score
Published: September 30, 2026 at 01:13 PM UTC
Updated: September 30, 2026 at 04:38 PM UTC
5 products affected across 1 vendorVaadinVaadin Charts FlowCharts

Using vaadin by vaadin?

Get instant alerts when new vulnerabilities affect vaadin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

A prototype pollution vulnerability exists in the deep merge helpers of Vaadin Charts and Vaadin Component Base. Merging an object the application does not control into a chart configuration or into a component's i18n property writes onto Object.prototype, making the injected properties visible to every object in the running application. Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include: Product version Vaadin 23.0.0 - 23.6.13 Vaadin 24.0.0 - 24.9.20 Vaadin 24.10.0 - 24.10.9 Vaadin 25.0.0 - 25.1.11 Vaadin 25.2.0 - 25.2.6 Mitigation Upgrade to 23.6.14 Upgrade to 24.9.21 Upgrade to 24.10.10 Upgrade to 25.1.12 Upgrade to 25.2.7 or newer Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, 25 version. Artifacts Maven coordinates Vulnerable versions Fixed version com.vaadin:vaadin 23.0.0 - 23.6.13 >=23.6.14 com.vaadin:vaadin 24.0.0 - 24.9.20 >=24.9.21 com.vaadin:vaadin 24.10.0 - 24.10.9 >=24.10.10 com.vaadin:vaadin 25.0.0 - 25.1.11 >=25.1.12 com.vaadin:vaadin 25.2.0 - 25.2.6 >=25.2.7 com.vaadin:vaadin-core 24.7.0 - 24.9.20 >=24.9.21 com.vaadin:vaadin-core 24.10.0 - 24.10.9 >=24.10.10 com.vaadin:vaadin-core 25.0.0 - 25.1.11 >=25.1.12 com.vaadin:vaadin-core 25.2.0 - 25.2.6 >=25.2.7 com.vaadin:vaadin-charts-flow 23.0.0 - 23.6.13 >=23.6.14 com.vaadin:vaadin-charts-flow 24.0.0 - 24.9.20 >=24.9.21 com.vaadin:vaadin-charts-flow 24.10.0 - 24.10.9 >=24.10.10 com.vaadin:vaadin-charts-flow 25.0.0 - 25.1.11 >=25.1.12 com.vaadin:vaadin-charts-flow 25.2.0 - 25.2.6 >=25.2.7 npm packages npm package Vulnerable versions Fixed version @vaadin/charts 23.0.0 - 23.6.4 >=23.6.5 @vaadin/charts 24.0.0 - 24.9.17 >=24.9.18 @vaadin/charts 24.10.0 - 24.10.4 >=24.10.5 @vaadin/charts 25.0.0 - 25.1.11 >=25.1.12 @vaadin/charts 25.2.0 - 25.2.8 >=25.2.9 @vaadin/component-base 24.7.0 - 24.9.17 >=24.9.18 @vaadin/component-base 24.10.0 - 24.10.4 >=24.10.5 @vaadin/component-base 25.0.0 - 25.1.11 >=25.1.12 @vaadin/component-base 25.2.0 - 25.2.8 >=25.2.9

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

23.0.0 ≤ v < 23.6.524.0.0 ≤ v < 24.9.1824.10.0 ≤ v < 24.10.525.0.0 ≤ v < 25.1.1225.2.0 ≤ v < 25.2.923.0.024.0.024.10.025.0.025.2.0
Affected range stops below 23.6.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.10.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.9.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.2.9, so it looks safe — our inference, not a vendor statement
24.10.0 ≤ v < 24.10.524.7.0 ≤ v < 24.9.1825.0.0 ≤ v < 25.1.1225.2.0 ≤ v < 25.2.924.10.024.7.025.0.025.2.0
Affected range stops below 24.10.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.9.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.2.9, so it looks safe — our inference, not a vendor statement
23.0.0 ≤ v < 23.6.1424.0.0 ≤ v < 24.9.2124.10.0 ≤ v < 24.10.1025.0.0 ≤ v < 25.1.1225.2.0 ≤ v < 25.2.723.0.024.0.024.10.025.0.025.2.0
Affected range stops below 23.6.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.10.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.9.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.2.7, so it looks safe — our inference, not a vendor statement
23.0.0 ≤ v < 23.6.1424.0.0 ≤ v < 24.9.2124.10.0 ≤ v < 24.10.1025.0.0 ≤ v < 25.1.1225.2.0 ≤ v < 25.2.723.0.024.0.024.10.025.0.025.2.0
Affected range stops below 23.6.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.10.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.9.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.2.7, so it looks safe — our inference, not a vendor statement
24.10.0 ≤ v < 24.10.1024.7.0 ≤ v < 24.9.2125.0.0 ≤ v < 25.1.1225.2.0 ≤ v < 25.2.724.10.024.7.025.0.025.2.0
Affected range stops below 24.10.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 24.9.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 25.2.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMVaadin
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-1321

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card