CVE-2026-88895

CyberPanel before 3.0.5 Authentication Bypass via API

HIGH
7.2
CVSS Score
Published: September 10, 2026 at 01:05 PM UTC
Updated: September 11, 2026 at 08:19 PM UTC
2 products affected across 2 vendorsCyberpanelCyberpanel

Using cyberpanel by usmannasir?

Get instant alerts when new vulnerabilities affect cyberpanel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

CyberPanel before 3.0.5 fails to enforce two-factor authentication on API endpoints, allowing attackers to bypass TOTP requirements using password-derived tokens. Attackers who obtain an administrator's password can derive API tokens and perform administrative operations or create authenticated sessions without the second factor.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.0.5
Affected range stops below 3.0.5, so it looks safe — our inference, not a vendor statement
v < 3.0.5
Vendor states this is fixed in 3.0.5 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.2HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card