CVE-2026-88057

Angular: Sanitization bypass via directive host bindings on concrete host elements in @angular/core and @angular/compiler

MEDIUM
6.1
CVSS Score
Published: September 10, 2026 at 06:46 PM UTC
Updated: September 29, 2026 at 07:02 PM UTC
1 product affected across 1 vendor@angular

Using angular by angular?

Get instant alerts when new vulnerabilities affect angular - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.28, 21.2.20, and 22.1.0, Angular's compiler and runtime in @angular/core and @angular/compiler could omit or select an incorrect sanitizer for security-sensitive directive host bindings because SecurityContext was derived from the declaring directive or component selector rather than the concrete host element. The mismatch is reachable through hostDirectives composition, inherited HostBinding declarations, createComponent with a custom hostElement or dynamic directives, SVG/MathML namespace elements, and tag-neutral selectors such as :not(...). Attacker-controlled href, src, action, xlink:href, or data values can therefore reach DOM attributes without Angular's built-in sanitizer and execute arbitrary JavaScript in the user's browser context. Applications unable to upgrade can use DomSanitizer.sanitize with SecurityContext.URL before assignment or restrict inputs to validated HTTP and HTTPS URL schemes. This issue is fixed in versions 20.3.28, 21.2.20, and 22.1.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 19.2.25v < 20.3.28v < 21.2.20v < 22.1.019.0.0 ≤ v ≤ 19.2.2520.0.0 ≤ v < 20.3.2821.0.0 ≤ v < 21.2.2022.0.0 ≤ v < 22.1.0
Affected range stops below 20.3.28, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1.0, so it looks safe — our inference, not a vendor statement

References (9)

x_refsource_CONFIRMExploitVendor Advisory
Source: cverecord
https://github.com/angular/angular/security/advisories/GHSA-hh8m-fm6v-7cvg
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/angular/angular/issues/69550
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/angular/angular/pull/69558
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/angular/angular/releases/tag/v20.3.28
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/angular/angular/releases/tag/v21.2.20

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card