CVE-2026-87908

multiparty vulnerable to Denial of Service via unbounded part-header accumulation

HIGH
7.5
CVSS Score
Published: September 11, 2026 at 06:37 AM UTC
Updated: September 16, 2026 at 07:54 PM UTC
1 product affected across 1 vendorMultiparty

Using multiparty by multiparty?

Get instant alerts when new vulnerabilities affect multiparty - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.1.0 ≤ v < 4.3.12.1.0
Vendor states this is fixed in 4.3.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-400CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card