CVE-2026-86193

Grav API Plugin Authentication Bypass via Group-Inherited Super

HIGH
8.7
CVSS Score
Published: September 5, 2026 at 12:09 PM UTC
Updated: September 8, 2026 at 08:19 PM UTC
2 products affected across 1 vendorGravGrav Plugin API

Using grav-plugin-api by getgrav?

Get instant alerts when new vulnerabilities affect grav-plugin-api - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.7
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

grav-plugin-api before 1.0.20 fails to validate group-inherited super permissions in user-management guards, allowing non-super user managers to modify super-admin accounts. Attackers with api.access and api.users.write can patch password fields on group-super accounts to gain full administrative control.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 1.0.20
Affected range stops below 1.0.20, so it looks safe — our inference, not a vendor statement
v < 1.0.20
Vendor states this is fixed in 1.0.20 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.7HIGHVulnCheck
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card