CVE-2026-85614

OpenPanel API before 2.3.0 Unauthenticated SSRF via site-checker

HIGH
8.6
CVSS Score
Published: September 4, 2026 at 11:30 AM UTC
Updated: October 2, 2026 at 02:00 PM UTC
1 product affected across 1 vendorOpenpanel

Using openpanel by Openpanel-dev?

Get instant alerts when new vulnerabilities affect openpanel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

OpenPanel before 2.3.0 contains an unauthenticated server-side request forgery vulnerability in the GET /tools/site-checker endpoint that accepts a fully client-controlled URL parameter with no private IP filtering or DNS-rebinding protection. Attackers can make the OpenPanel server issue requests to internal services, localhost, and cloud metadata endpoints, reading internal HTTP response titles, headers, status codes, and SSL certificate information.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.3.0
Vendor states this is fixed in 2.3.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.6HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card