CVE-2026-83557

jackson-databind omits java.lang.Comparable from DefaultBaseTypeLimitingValidator's unsafe base types

MEDIUM
5.6
CVSS Score
Published: September 1, 2026 at 02:57 PM UTC
Updated: September 8, 2026 at 07:29 PM UTC
1 product affected across 1 vendorJackson Databind

Using jackson-databind by FasterXML?

Get instant alerts when new vulnerabilities affect jackson-databind - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.6
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

DefaultBaseTypeLimitingValidator is the PolymorphicTypeValidator applied automatically whenever @JsonTypeInfo is used without an explicitly configured custom validator. It denies polymorphic resolution only for a fixed set of "unsafe base types", and its isSafeSubType method returns true unconditionally for every base type outside that set. java.lang.Comparable was absent from the list despite being implemented by a very large fraction of JDK and application classes, comparable in breadth to java.io.Serializable, which is on the list for that reason. An application declaring an @JsonTypeInfo-annotated property or class with Comparable as its base type, and no custom PolymorphicTypeValidator, will accept a type identifier for essentially any class implementing Comparable. This yields an attacker-controlled object instantiation primitive; a demonstrated case constructs a java.io.File for an arbitrary attacker-chosen path, which becomes path-traversal-adjacent if the application subsequently calls path-sensitive methods on the value. No class implementing Comparable has been identified that yields code execution through deserialization alone. Global Default Typing via activateDefaultTyping is not affected, because that method structurally requires an explicit PolymorphicTypeValidator argument. This affects com.fasterxml.jackson.core:jackson-databind from 2.11.0 before 2.18.10, from 2.19.0 before 2.21.6, and from 2.22.0 before 2.22.2, and tools.jackson.core:jackson-databind from 3.0.0 before 3.1.6 and from 3.2.0 before 3.2.2. Users should upgrade to 2.18.10, 2.21.6, 2.22.2, 3.1.6, or 3.2.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.11.0 ≤ v < 2.18.102.19.0 ≤ v < 2.21.62.22.0 ≤ v < 2.22.23.0.0 ≤ v < 3.1.63.2.0 ≤ v < 3.2.22.11.02.19.02.22.03.0.03.2.0
Affected range stops below 2.18.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.21.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.22.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.2.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.6MEDIUMHeroDevs
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-502CWE-915

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card