CVE-2026-82864

pdfme pdf-lib before 5.5.10 Denial of Service via Decompression Bomb

MEDIUM
6.5
CVSS Score
Published: August 31, 2026 at 08:46 AM UTC
Updated: October 8, 2026 at 04:17 PM UTC
2 products affected across 2 vendorsPdflibPDF Lib

Using pdf-lib by pdfme?

Get instant alerts when new vulnerabilities affect pdf-lib - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

pdfme pdf-lib versions before 5.5.10 contain an unbounded buffer growth vulnerability in the DecodeStream.ensureBuffer() method that allows attackers to cause denial of service by supplying a crafted PDF with a FlateDecode stream containing a decompression bomb. Attackers can upload a small compressed PDF that decompresses to hundreds of megabytes, exhausting memory and crashing the Node.js process or freezing browser tabs during PDF parsing.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.5.10
Affected range stops below 5.5.10, so it looks safe — our inference, not a vendor statement
0 ≤ v < 5.5.100
Vendor states this is fixed in 5.5.10 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-409

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card