CVE-2026-82806

Apache APISIX: cross-request permission pollution via static permission list mutation

MEDIUM
5.3
CVSS Score
Published: October 1, 2026 at 10:58 AM UTC
Updated: October 1, 2026 at 03:17 PM UTC
1 product affected across 1 vendorApisix

Using Apache APISIX by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache APISIX - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.3.0 ≤ v < 3.7.02.3.0
Affected range stops below 3.7.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMapache
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-488

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card