CVE-2026-79770

Nokogiri before 1.19.3 ReDoS via CSS selector tokenizer

HIGH
7.5
CVSS Score
Published: August 25, 2026 at 03:16 PM UTC
Updated: September 1, 2026 at 03:31 PM UTC
2 products affected across 2 vendorsNokogiriNokogiri

Using nokogiri by sparklemotion?

Get instant alerts when new vulnerabilities affect nokogiri - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Nokogiri versions before 1.19.3 contain regular expression denial of service vulnerabilities in the CSS selector tokenizer affecting string-literal and identifier tokenization. Attackers can inject adversarial CSS selectors into methods like Node#css, Node#at_css, and Searchable#search to cause exponential regex backtracking and denial of service.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.19.3
Affected range stops below 1.19.3, so it looks safe — our inference, not a vendor statement
v < 1.19.3
Vendor states this is fixed in 1.19.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-1333

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card