CVE-2026-77912

Stored cross-site scripting vulnerability in GitHub Enterprise Server allowed HTML attribute injection via the Markdown rendering pipeline

MEDIUM
5.4
CVSS Score
Published: September 22, 2026 at 08:43 PM UTC
Updated: October 2, 2026 at 06:38 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

A stored cross-site scripting (XSS) vulnerability was identified in GitHub Enterprise Server that allowed an authenticated attacker to inject arbitrary HTML attributes into rendered Markdown because the Markdown rendering pipeline rewrote quote characters in already-sanitized HTML without re-sanitizing the result. Crafted Markdown could abuse same-origin JavaScript gadgets to bypass Content Security Policy and gain control of the page DOM when viewed by another user. Successful exploitation could allow an attacker to read content visible to the victim, extract embedded CSRF tokens, perform state-changing actions as the victim, and exfiltrate data through same-origin writes. The payload could also propagate to repositories and organizations where the victim had write access. This vulnerability affected supported GitHub Enterprise Server releases in the 3.17, 3.18, 3.19, 3.20, 3.21, and 3.22 series and was fixed in versions 3.22.1, 3.21.6, 3.20.8, 3.19.12, 3.18.15, and 3.17.21. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.17.0 ≤ v < 3.17.*3.17.0 ≤ v < 3.17.213.18.0 ≤ v < 3.18.*3.18.0 ≤ v < 3.18.153.19.0 ≤ v < 3.19.*3.19.0 ≤ v < 3.19.123.20.0 ≤ v < 3.20.*3.20.0 ≤ v < 3.20.83.21.0 ≤ v < 3.21.*3.21.0 ≤ v < 3.21.63.22.0 ≤ v < 3.22.*3.22.0 ≤ v < 3.22.13.17.03.18.03.19.03.20.03.21.03.22.0
Affected range stops below 3.17.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.22.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.22.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card