CVE-2026-7776

Boundary Workers Vulnerable to Denial of Service During TLS Handshake

HIGH
7.5
CVSS Score
Published: May 4, 2026 at 09:34 PM UTC
Updated: June 17, 2026 at 11:02 AM UTC
1 product affected across 1 vendorBoundary

Using Boundary by HashiCorp?

Get instant alerts when new vulnerabilities affect Boundary - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

Boundary Community Edition and Boundary Enterprise (“Boundary”) workers are vulnerable to a denial-of-service condition during node enrollment TLS handshakes. An attacker with network access to the worker authentication listener may open a connection and delay or withhold the client certificate during the TLS handshake, causing worker connection handling to block. This may prevent legitimate worker connections from being accepted or routed. This vulnerability, CVE-2026-7776, is fixed in Boundary 0.21.3, 0.20.3, 0.19.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.9.0 ≤ v < 0.21.30.9.0
Affected range stops below 0.21.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHHashiCorp
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card