CVE-2026-77147

Apache Syncope: Groovy Sandbox escape for empty CommandArgs

MEDIUM
6.5
CVSS Score
Published: September 14, 2026 at 12:49 PM UTC
Updated: September 14, 2026 at 09:14 PM UTC
1 product affected across 1 vendorSyncope

Using Apache Syncope by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Syncope - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.0.0-M0 ≤ v ≤ 3.0.164.0.0-M0 ≤ v ≤ 4.0.74.1.0-M0 ≤ v ≤ 4.1.23.0.0-M04.0.0-M04.1.0-M0

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card