CVE-2026-77078

multer vulnerable to Denial of Service via crafted multipart field names

HIGH
7.5
CVSS Score
Published: August 28, 2026 at 08:03 PM UTC
Updated: September 2, 2026 at 03:02 PM UTC
2 products affected across 2 vendorsMulterMulter

Using multer by multer?

Get instant alerts when new vulnerabilities affect multer - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.3.0
Affected range stops below 2.3.0, so it looks safe — our inference, not a vendor statement
v < 2.3.0
Vendor states this is fixed in 2.3.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Vector?

Quick Info

StatusANALYZED
CWE
CWE-248

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card