CVE-2026-76986

Apache Wicket: XSS in AbstractSingleSelectChoice via getNullValidDisplayValue

MEDIUM
6.1
CVSS Score
Published: August 31, 2026 at 01:25 PM UTC
Updated: September 1, 2026 at 06:21 PM UTC
1 product affected across 1 vendorWicket

Using Apache Wicket by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Wicket - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Improper neutralization of input during web page generation in Apache Wicket. org.apache.wicket.markup.html.form.AbstractSingleSelectChoice, the base class of DropDownChoice, writes the body of the default option — the entry shown when no choice is selected — into the markup as it is, while every other option body in the same select is escaped according to the escape-model-strings setting. The body comes from getNullValidDisplayValue() or getNullKeyDisplayValue(), both of which are protected, so what they return is not necessarily the plain text the default implementation reads from a resource bundle. An application is affected where it overrides one of those methods and returns a value holding data an attacker can influence, or where its own nullValid or null bundle entry holds such a value. The bundles shipped with Wicket contain plain text. RadioChoice overrides getDefaultChoice to emit no default option and is not affected. As a workaround, escape the value in the override. This issue affects Apache Wicket: from 8.0.0 through 8.18.0, from 9.0.0 through 9.23.0, from 10.0.0 through 10.10.0. Older, unsupported releases from 1.5.0 onwards are also affected. Users are recommended to upgrade to version 8.19.0, 9.24.0 or 10.11.0, which fix the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0.0 ≤ v ≤ 10.10.010.0.0 ≤ v < 10.11.08.0.0 ≤ v ≤ 8.18.08.0.0 ≤ v < 8.19.09.0.0 ≤ v ≤ 9.23.09.0.0 ≤ v < 9.24.010.0.08.0.09.0.0
Affected range stops below 10.11.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.19.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.24.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor AdvisoryMailing List
Source: cverecord
https://lists.apache.org/thread/4qltg6wckqz8wbs1f4jzqlc0yccpgvll
Mailing ListThird Party Advisory
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/08/31/6

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card