CVE-2026-76851

Server-Side Request Forgery vulnerability in GitHub Enterprise Server allowed remote code execution via network access from pre-receive hooks to internal services

HIGH
8.8
CVSS Score
Published: September 1, 2026 at 09:55 PM UTC
Updated: September 8, 2026 at 01:31 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed remote code execution on the instance. Insufficient network isolation allowed malicious pre-receive hook code to impersonate an internal service and redirect trusted internal requests to a privileged service, leading to elevated code execution. Exploitation required pre-receive hook networking to be enabled and either site administrator privileges or write access to a repository containing a configured pre-receive hook. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.20, 3.18.14, 3.19.11, 3.20.7, and 3.21.5. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.17.203.17.0 ≤ v ≤ 3.17.193.18.0 ≤ v ≤ 3.18.133.18.0 ≤ v < 3.18.143.19.0 ≤ v ≤ 3.19.103.19.0 ≤ v < 3.19.113.20.0 ≤ v ≤ 3.20.63.20.0 ≤ v < 3.20.73.21.0 ≤ v ≤ 3.21.43.21.0 ≤ v < 3.21.53.17.03.18.03.19.03.20.03.21.0
Affected range stops below 3.17.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.22.0 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card