CVE-2026-76801

FireBox <= 3.1.10 - Authenticated (Author+) Remote Code Execution to Privilege Escalation

HIGH
8.8
CVSS Score
Published: September 9, 2026 at 02:27 AM UTC
Updated: September 9, 2026 at 05:27 PM UTC
1 product affected across 1 vendorFireBox

Using FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment by fireplugins?

Get instant alerts when new vulnerabilities affect FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

The FireBox – WooCommerce Popup Builder, Exit Intent Popup, Email Optin & Cart Abandonment plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 3.1.10 via the value function. This is due to a trivially bypassable regex blacklist in Executer::allowedToRun() that fails to block WordPress core functions such as wp_insert_user, update_option, and file_put_contents, combined with no sanitization of PHP condition rule values stored via the firebox_meta REST endpoint. This makes it possible for authenticated attackers, with author-level access and above, to execute code on the server. On sites upgraded from a version prior to 3.1.10, the Migrator::preserveCampaignRoleAccess() function automatically grants the edit_fireboxes and publish_fireboxes capabilities to the Author role, lowering the effective entry point to Author-level access.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

FireBox· Firepluginswordpress-plugin
60%
v ≤ 3.1.10

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card