CVE-2026-7660

Easy Updates Manager <= 9.0.20 - Reflected Cross-Site Scripting via 'paged' Parameter

MEDIUM
6.1
CVSS Score
Published: May 28, 2026 at 06:45 AM UTC
Updated: June 17, 2026 at 11:02 AM UTC
1 product affected across 1 vendorEasy Updates Manager

Using Easy Updates Manager by davidanderson?

Get instant alerts when new vulnerabilities affect Easy Updates Manager - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

The Easy Updates Manager plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'paged' parameter in versions up to, and including, 9.0.20 This is due to insufficient input sanitization and output escaping in the pagination() function. This makes it possible for attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page granted they can trick an administrator into performing an action such as clicking on a link.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 9.0.20

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.1MEDIUMWordfence
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card