CVE-2026-76172

fast-uri vulnerable to host confusion via percent-encoded scheme normalization

HIGH
7.5
CVSS Score
Published: August 24, 2026 at 10:07 AM UTC
Updated: October 14, 2026 at 01:10 PM UTC
2 products affected across 2 vendorsFast UriFast Uri

Using fast-uri by fast-uri?

Get instant alerts when new vulnerabilities affect fast-uri - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.3.1 ≤ v < 2.4.53.0.0 ≤ v < 3.1.64.0.0 ≤ v < 4.1.3
Affected range stops below 2.4.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.3, so it looks safe — our inference, not a vendor statement
2.3.1 ≤ v < 2.4.53.0.0 ≤ v < 3.1.64.0.0 ≤ v < 4.1.32.3.13.0.04.0.0
Vendor states this is fixed in 2.4.5 (unaffected)
Vendor states this is fixed in 3.1.6 (unaffected)
Vendor states this is fixed in 4.1.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Vector?

Quick Info

StatusANALYZED
CWE
CWE-177

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card