CVE-2026-76086

Formie: Integration form-settings action allows SSRF and exfiltration of stored integration credentials

HIGH
8.5
CVSS Score
Published: September 23, 2026 at 06:32 PM UTC
Updated: September 30, 2026 at 07:57 PM UTC
1 product affected across 1 vendorFormie

Using formie by verbb?

Get instant alerts when new vulnerabilities affect formie - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Formie is a Craft CMS plugin for creating forms. Prior to 2.2.23 and 3.1.31, Formie's formie/integrations/form-settings control panel action in IntegrationsController::actionFormSettings is reachable without the required form integration permissions and passes request-supplied settings to a configured integration. An authenticated attacker can replace outbound host properties such as apiUrl while the server uses stored API keys or OAuth tokens, causing non-blind server-side requests to an attacker-controlled or internal host and returning the remote response. This residual flaw remained because the permission gate added in version 3.1.28 excluded the form-settings action. Sites that permit low-privileged or front-end user authentication can therefore expose integration credentials and internal network responses. This issue is fixed in versions 2.2.23 and 3.1.31.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

60%
v < 2.2.23v < 3.1.31
Affected range stops below 2.2.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.31, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-862CWE-915CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card