CVE-2026-75975

fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization

HIGH
7.5
CVSS Score
Published: August 24, 2026 at 09:58 AM UTC
Updated: October 14, 2026 at 01:10 PM UTC
2 products affected across 2 vendorsFast UriFast Uri

Using fast-uri by fast-uri?

Get instant alerts when new vulnerabilities affect fast-uri - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions2.3.1 ≤ v < 2.4.53.0.0 ≤ v < 3.1.64.0.0 ≤ v < 4.1.3
Affected range stops below 2.4.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.3, so it looks safe — our inference, not a vendor statement
2.3.1 ≤ v < 2.4.53.0.0 ≤ v < 3.1.64.0.0 ≤ v < 4.1.32.3.13.0.04.0.0
Vendor states this is fixed in 2.4.5 (unaffected)
Vendor states this is fixed in 3.1.6 (unaffected)
Vendor states this is fixed in 4.1.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Vector?

Quick Info

StatusANALYZED
CWE
CWE-20CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card