CVE-2026-75915

CodeWhale before 0.8.64 Environment Variable Leak via js_execution

HIGH
7.5
CVSS Score
Published: August 18, 2026 at 03:22 PM UTC
Updated: October 22, 2026 at 10:10 PM UTC
1 product affected across 1 vendorCodeWhale

Using CodeWhale by Hmbown?

Get instant alerts when new vulnerabilities affect CodeWhale - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript code executed by the tool to read process.env and leak API keys, cloud credentials, and authentication tokens back to the model context.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.8.32 ≤ v < 0.8.410.8.41 ≤ v < 0.8.640.8.320.8.41
Vendor states this is fixed in 0.8.41 (unaffected)
Vendor states this is fixed in 0.8.64 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card