CVE-2026-75912

CodeWhale before 0.8.64 Argument Injection via git_blame

HIGH
7.4
CVSS Score
Published: August 18, 2026 at 03:22 PM UTC
Updated: October 22, 2026 at 10:10 PM UTC
1 product affected across 1 vendorCodeWhale

Using CodeWhale by Hmbown?

Get instant alerts when new vulnerabilities affect CodeWhale - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.4
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter. Attackers can supply rev values like --contents=/path/to/file to exfiltrate sensitive files such as SSH keys and credentials through the tool output returned to the model.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.3.27 ≤ v < 0.8.410.8.41 ≤ v < 0.8.640.3.270.8.41
Vendor states this is fixed in 0.8.41 (unaffected)
Vendor states this is fixed in 0.8.64 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.4HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-88

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card