CVE-2026-75911

CodeWhale before 0.8.64 Remote Code Execution via allow_shell

HIGH
7.8
CVSS Score
Published: August 18, 2026 at 03:21 PM UTC
Updated: October 22, 2026 at 10:10 PM UTC
1 product affected across 1 vendorCodeWhale

Using CodeWhale by Hmbown?

Get instant alerts when new vulnerabilities affect CodeWhale - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.2%
SSVC
PoC

Description

CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.8.41 ≤ v < 0.8.640.8.6 ≤ v < 0.8.410.8.410.8.6
Vendor states this is fixed in 0.8.41 (unaffected)
Vendor states this is fixed in 0.8.64 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.8HIGHVulnCheck
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card