CVE-2026-75899

fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding

HIGH
7.5
CVSS Score
Published: August 24, 2026 at 09:40 AM UTC
Updated: October 14, 2026 at 01:10 PM UTC
2 products affected across 2 vendorsFast UriFast Uri

Using fast-uri by fast-uri?

Get instant alerts when new vulnerabilities affect fast-uri - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions2.4.1 ≤ v < 2.4.53.1.2 ≤ v < 3.1.64.0.0 ≤ v < 4.1.3
Affected range stops below 2.4.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.3, so it looks safe — our inference, not a vendor statement
2.4.1 ≤ v < 2.4.53.1.2 ≤ v < 3.1.64.0.0 ≤ v < 4.1.32.4.13.1.24.0.0
Vendor states this is fixed in 2.4.5 (unaffected)
Vendor states this is fixed in 3.1.6 (unaffected)
Vendor states this is fixed in 4.1.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHopenjs
Vector?

Quick Info

StatusANALYZED
CWE
CWE-174CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card