CVE-2026-75845

ArcadeDB 26.4.2 before 26.8.1 Authorization Bypass via set_server_setting

MEDIUM
6.3
CVSS Score
Published: August 18, 2026 at 11:19 AM UTC
Updated: October 22, 2026 at 10:10 PM UTC
1 product affected across 1 vendorArcadeDB

Using arcadedb by ArcadeData?

Get instant alerts when new vulnerabilities affect arcadedb - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

ArcadeDB versions 26.4.2 through 26.7.3 contain an authorization bypass vulnerability in the set_server_setting MCP server-level tool. SetServerSettingTool.execute() gates only on the global allowAdmin flag and never checks the caller's role, so in an MCP deployment with allowAdmin=true and a non-root allowedUsers set, any authenticated read-only user can invoke set_server_setting to modify server GlobalConfiguration, enabling configuration tampering or denial of service. The issue is fixed in 26.8.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

26.4.2 ≤ v < 26.8.126.4.2
Vendor states this is fixed in 26.8.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card