CVE-2026-75829

grav-plugin-api before 1.0.15 Twig SSTI via translate endpoint

HIGH
8.1
CVSS Score
Published: August 18, 2026 at 11:19 AM UTC
Updated: October 22, 2026 at 10:10 PM UTC
1 product affected across 1 vendorGrav

Using grav by getgrav?

Get instant alerts when new vulnerabilities affect grav - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

grav-plugin-api versions before 1.0.15 fail to validate Twig content in the translate() endpoint, allowing attackers with api.pages.write permission to persist pages with process.twig enabled. Attackers can submit crafted header and content parameters to execute server-side template injection payloads that are evaluated at render time.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

90%
0 ≤ v < 1.0.150
Vendor states this is fixed in 1.0.15 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.1HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-1336

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card