CVE-2026-75101

Authorization bypass vulnerability in GitHub Enterprise Server allowed reading of private pull request diffs and patches via repository name collision

MEDIUM
6.5
CVSS Score
Published: September 22, 2026 at 08:43 PM UTC
Updated: October 2, 2026 at 06:46 PM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

An authorization bypass vulnerability was identified in GitHub Enterprise Server that allowed any authenticated user of the instance to read the raw diff or patch of pull requests in private repositories without authorization. Access tokens for raw pull request diffs and patches were scoped to the repository name and pull request number rather than to a globally unique repository identifier, so an attacker who created a repository and pull request matching a target's repository name and pull request number could use a token for their own repository to retrieve the private pull request's contents. Exploitation required the attacker to know the target repository's name and a valid pull request number. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.21, 3.18.15, 3.19.12, 3.20.8, and 3.21.6. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.17.0 ≤ v < 3.17.*3.17.0 ≤ v < 3.17.213.18.0 ≤ v < 3.18.*3.18.0 ≤ v < 3.18.153.19.0 ≤ v < 3.19.*3.19.0 ≤ v < 3.19.123.20.0 ≤ v < 3.20.*3.20.0 ≤ v < 3.20.83.21.0 ≤ v < 3.21.*3.21.0 ≤ v < 3.21.63.17.03.18.03.19.03.20.03.21.0
Affected range stops below 3.17.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.17.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.18.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.19.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.20.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.*, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.21.6, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-639

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card