CVE-2026-73626

JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager

HIGH
7.5
CVSS Score
Published: August 13, 2026 at 11:28 AM UTC
Updated: September 9, 2026 at 08:47 PM UTC
2 products affected across 2 vendorsJupyterlabJupyterlab

Using jupyterlab by jupyterlab?

Get instant alerts when new vulnerabilities affect jupyterlab - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.5.104.6.0 ≤ v < 4.6.1
Affected range stops below 4.5.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.1, so it looks safe — our inference, not a vendor statement
v < 4.5.104.6.0 ≤ v < 4.6.14.6.0
Vendor states this is fixed in 4.5.10 (unaffected)
Vendor states this is fixed in 4.6.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHVulnCheck
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusAWAITING ANALYSIS
CWE
CWE-284

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card