CVE-2026-73625

GitPython before 3.1.54 Remote Code Execution via kwarg value smuggling

HIGH
8.8
CVSS Score
Published: August 13, 2026 at 11:28 AM UTC
Updated: October 24, 2026 at 03:10 PM UTC
2 products affected across 2 vendorsGitpythonGitPython

Using GitPython by gitpython-developers?

Get instant alerts when new vulnerabilities affect GitPython - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

GitPython versions before 3.1.54 contain a remote code execution vulnerability in the check_unsafe_options guard that can be bypassed by smuggling git options inside single-character kwarg values. Attackers can supply crafted option dictionaries to clone_from, fetch, pull, push, ls_remote, iter_commits, blame, or archive methods to execute arbitrary OS commands via the --upload-pack parameter.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versionsv < 3.1.54
Affected range stops below 3.1.54, so it looks safe — our inference, not a vendor statement
0 ≤ v < 3.1.54
Vendor states this is fixed in 3.1.54 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card