CVE-2026-73623

GitPython before 3.1.54 Remote Code Execution via --template

HIGH
8.8
CVSS Score
Published: August 13, 2026 at 11:28 AM UTC
Updated: October 24, 2026 at 03:10 PM UTC
2 products affected across 2 vendorsGitpythonGitPython

Using GitPython by gitpython-developers?

Get instant alerts when new vulnerabilities affect GitPython - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.8%
SSVC
PoC

Description

GitPython before 3.1.54 contains an incomplete denylist in unsafe_git_clone_options that omits --template, allowing attackers to achieve arbitrary command execution during clone operations. Attackers can supply --template pointing to a directory containing malicious post-checkout hooks that execute when git clones the repository.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.1.54
Affected range stops below 3.1.54, so it looks safe — our inference, not a vendor statement
0 ≤ v < 3.1.54
Vendor states this is fixed in 3.1.54 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card