CVE-2026-73494

blaze: Multiple HTTP/1.1 request-smuggling primitives in blaze's Java wire parser

HIGH
7.4
CVSS Score
Published: September 14, 2026 at 05:33 PM UTC
Updated: September 30, 2026 at 05:51 PM UTC
3 products affected across 2 vendorsBlazeBlaze HTTPHTTP4S Blaze Server

Using blaze by http4s?

Get instant alerts when new vulnerabilities affect blaze - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.4
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

blaze is a Scala library for building asynchronous pipelines, with a focus on network IO. Prior to 0.23.18 and from 1.0.0-M1 until 1.0.0-M42, five HTTP/1.1 conformance laxities in the hand-written Java parser under http/src/main/java/org/http4s/blaze/http/parser/ can cause blaze to derive a different request boundary than a stricter fronting intermediary. A default BlazeServerBuilder accepts invalid or valueless header field names that violate tchar syntax, obsolete folded field lines (obs-fold), unsupported Transfer-Encoding values, duplicate Content-Length fields, and requests containing both Transfer-Encoding and Content-Length. If a lenient or legacy proxy forwards the malformed bytes but interprets them differently, the disagreement can permit front-end authorization bypass, response-queue poisoning on pooled backend connections, or cache poisoning. Exploitation requires a pair of disagreeing parsers; no non-default blaze configuration is required. The affected checks are enforced in BodyAndHeaderParser and Http1ServerParser. This issue is fixed in versions 0.23.18 and 1.0.0-M42.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.23.18v < 1.0.0-M42
Affected range stops below 0.23.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.0.0-M42, so it looks safe — our inference, not a vendor statement
v < 0.23.18v < 1.0.0-M42
Affected range stops below 0.23.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.0.0-M42, so it looks safe — our inference, not a vendor statement
v < 0.23.18
Affected range stops below 0.23.18, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.4HIGHGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-444

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card