CVE-2026-73255

Mongoose: Path traversal in SSI #include directives enables arbitrary file read

MEDIUM
6.5
CVSS Score
Published: August 20, 2026 at 05:40 PM UTC
Updated: October 18, 2026 at 08:10 PM UTC
1 product affected across 1 vendorMongoose

Using mongoose by cesanta?

Get instant alerts when new vulnerabilities affect mongoose - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.7%
SSVC
PoC

Description

Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 7.22
Affected range stops below 7.22, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

x_refsource_CONFIRMExploitVendor Advisory
Source: cverecord
https://github.com/cesanta/mongoose/security/advisories/GHSA-h7m9-764r-7x4x
x_refsource_MISCIssue TrackingPatch
Source: cverecord
https://github.com/cesanta/mongoose/pull/3611
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/cesanta/mongoose/releases/tag/7.22

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card