CVE-2026-73180

Apache Tomcat: Authenticated WebSocket session survives end of HTTP session

MEDIUM
6.8
CVSS Score
Published: August 25, 2026 at 10:01 PM UTC
Updated: August 27, 2026 at 12:51 PM UTC
1 product affected across 1 vendorTomcat

Using Apache Tomcat by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Tomcat - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.8
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.1.0 ≤ v < 10.1.5810.1.0-M1 ≤ v ≤ 10.1.5711.0.0 ≤ v < 11.0.2511.0.0-M1 ≤ v ≤ 11.0.247.0.43 ≤ v ≤ 7.0.1098.5.0 ≤ v ≤ 8.5.1008.5.0 ≤ v < 9.0.1219.0.0.M1 ≤ v ≤ 9.0.12010.1.0-M111.0.0-M17.0.438.5.09.0.0.M1
Affected range stops below 10.1.58, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.0.25, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 7.0.43 (unaffected)
Affected range stops below 9.0.121, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor AdvisoryMailing List
Source: cverecord
https://lists.apache.org/thread/3j15vztszpyqss253mjq5v1kp7s6hooq
Third Party AdvisoryMailing List
Source: af854a3a-2127-422b-91ae-364da2661108
http://www.openwall.com/lists/oss-security/2026/08/26/10

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.8MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-613

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card