CVE-2026-72857

Budibase before 3.40.0 Credential Exposure via STRING Fields

HIGH
7.7
CVSS Score
Published: August 13, 2026 at 09:54 PM UTC
Updated: August 31, 2026 at 08:46 PM UTC
1 product affected across 1 vendorBudibase

Using budibase by Budibase?

Get instant alerts when new vulnerabilities affect budibase - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.7
Exploit prediction
EPSS 0.4%
SSVC
PoC

Description

Budibase before 3.40.0 fails to redact datasource credentials stored in STRING typed fields, allowing authenticated users to read MongoDB connection strings and Firebase private keys in plaintext. Attackers with table read permissions can retrieve datasource configurations through the read API to obtain live backend database credentials and service account keys.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.40.0
Vendor states this is fixed in 3.40.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.7HIGHVulnCheck
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-522

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card