CVE-2026-70654

libvips: A well-crafted PPM image processed via a custom source could lead to possible heap buffer write overflow

MEDIUM
5.8
CVSS Score
Published: August 20, 2026 at 09:07 PM UTC
Updated: October 26, 2026 at 10:10 AM UTC
1 product affected across 1 vendorLibvips

Using libvips by libvips?

Get instant alerts when new vulnerabilities affect libvips - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.8
Exploit prediction
EPSS 0.1%
SSVC
No known exploit

Description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 8.18.3
Affected range stops below 8.18.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.8MEDIUMGitHub_M
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-122

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card