CVE-2026-70405

snmp BER INTEGER decoder applies no size limit to attacker-supplied integer fields

MEDIUM
6.3
CVSS Score
Published: September 1, 2026 at 02:50 PM UTC
Updated: September 8, 2026 at 01:17 AM UTC
1 product affected across 1 vendorErlang /otp

Using OTP by Erlang?

Get instant alerts when new vulnerabilities affect OTP - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

Improper Validation of Specified Quantity in Input vulnerability in Erlang/OTP snmp allows a remote attacker to degrade availability by sending an SNMP message containing a BER INTEGER whose length field is arbitrarily large. snmp_pdus:dec_integer_notag/1 defaults its size limit to infinity, and do_dec_integer_notag/2 then accumulates the value across every declared byte with a recursive shift and bitwise or. Work grows superlinearly in the declared length because each operation acts on a progressively larger bignum. The size-limited variant dec_integer_notag/2 exists but is reached from only one call site, dec_snmp_version/1, which bounds the version field to ten bytes; the request identifier, error status and index, generic and specific trap fields, engine boots and time, and every varbind value decoded by dec_value/1 all use the unbounded form. The decode runs before the PDU is processed, so no valid request is required beyond what the deployment demands to accept the message at all. This issue affects OTP from OTP 17.0 before OTP 27.3.4.17, from OTP 28.0 before OTP 28.5.0.6, and from OTP 29.0 before OTP 29.0.6, corresponding to snmp from 4.25.1 before 5.18.2.1, from 5.19 before 5.20.2.2, and from 5.20.3 before 5.20.5. Whether OTP before OTP 17.0, corresponding to snmp before 4.25.1, is affected is unknown.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 27.3.4.1717.0 ≤ v < 27.3.4.1728.0 ≤ v < 28.5.0.629.0 ≤ v < 29.0.64.25.1 ≤ v < 5.18.2.15.19 ≤ v < 5.20.2.25.20.3 ≤ v < 5.20.517.028.029.04.25.15.195.20.384adefa331c4159d432d22840663c38f155cd4c1
Affected range stops below 27.3.4.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 28.5.0.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 29.0.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.18.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.20.2.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.20.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 17.0 (unknown)
Vendor states this is fixed in 4.25.1 (unknown)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMEEF
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-1284

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card