CVE-2026-68368

usb: gadget: f_ncm: validate datagram bounds in ncm_unwrap_ntb()

N/A
Published: August 10, 2026 at 12:03 PM UTC
Updated: August 19, 2026 at 05:20 PM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 0.2%

Description

In the Linux kernel, the following vulnerability has been resolved: usb: gadget: f_ncm: validate datagram bounds in ncm_unwrap_ntb() When unpacking host-supplied NTBs, ncm_unwrap_ntb() checks datagram length against frame_max but does not verify that the datagram fits within the declared block length. Additionally, when decoding multiple NTBs from a single socket buffer, subsequent block lengths are not checked against the actual remaining buffer data. With these checks missing, a malicious USB host can specify datagram offsets and lengths that point beyond the block, or supply secondary NTB headers declaring lengths larger than the buffer. skb_put_data() then copies adjacent kernel memory from skb_shared_info into the network skb. Fix this by verifying that sufficient buffer space remains for the NTB header before parsing, handling zero-length block declarations, ensuring that block lengths never exceed the remaining buffer space, and verifying that each datagram payload stays strictly within the block boundary.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 4.14.196v ≥ 4.14.328v ≥ 4.19.143v ≥ 4.19.297v ≥ 4.9.235v ≥ 5.4.259v ≥ 5.4.62v ≥ 5.8.64.14.196 ≤ v < 4.154.14.328 ≤ v < 4.154.19.143 ≤ v < 4.204.19.297 ≤ v < 4.204.9.235 ≤ v < 4.105.4.259 ≤ v < 5.55.4.62 ≤ v < 5.55.8.6 ≤ v < 5.95.9 ≤ v < 5.10.2655.9 ≤ v < 5.15.2165.9 ≤ v < 6.1.1835.9 ≤ v < 6.12.1015.9 ≤ v < 6.18.425.9 ≤ v < 6.6.1485.9 ≤ v < 7.1.65.9 ≤ v < 7.22b74b0a04d3e9f9f08ff026e5663dce88ff94e524.14.1964.14.3284.19.1434.19.2974.9.235471b23586387a32857778c511be60ab31c98dcfd4f529c4d1e436230d3af7c09a3239677a14d2b465.4.2595.4.625.8.65.95bdf93a2f5459f944b416b188178ca4a92fd206fae6a5394d9fbe118bc95cfe376d6a9d91d7547e8b88ad6e714284b33a47834f5f2a294c2b37c66aae7ca00f35d8a17af1ae19d529193ebc21bfda164f7e0611e207d8908c4f2858e244370529a76dbf7ff3ba016263ee93a1c6209bf5ab1599de7ab1512
Vendor states this is fixed in 1febec7e47cdcd01f43fb0211094e3010474666e (fixed)
Vendor states this is fixed in 35d15bbaec0557330e774ec31412ef508de6e0e0 (fixed)
Vendor states this is fixed in 40c706a0224bde194667e3378c689b542fec4b44 (fixed)
Vendor states this is fixed in 41fd5f2fb0027d3773ae949e3247c2e0a2a7fe5c (fixed)
Vendor states this is fixed in 6b2be489eaa6293e60549005d91f15ceb150510f (fixed)
Vendor states this is fixed in e07751d0527ccc2a1c32eb0b0b7da3b4b9b5381f (fixed)
Vendor states this is fixed in f87ed889f0f7417b8938c98d8833f559b755373c (fixed)
Vendor states this is fixed in fff1059d139ef798bab917990524faaf25854ca8 (fixed)
Affected range stops below 4.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.20, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.10.265 (unaffected)
Vendor states this is fixed in 5.15.216 (unaffected)
Affected range stops below 5.5, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.9 (unaffected)
Vendor states this is fixed in 6.1.183 (unaffected)
Vendor states this is fixed in 6.12.101 (unaffected)
Vendor states this is fixed in 6.18.42 (unaffected)
Vendor states this is fixed in 6.6.148 (unaffected)
Vendor states this is fixed in 7.1.6 (unaffected)
Vendor states this is fixed in 7.2 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

Quick Info

StatusRECEIVED

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card