CVE-2026-67420

RabbitMQ OAuth credential refresh retains revoked runtime tags

MEDIUM
6.5
CVSS Score
Published: September 25, 2026 at 04:42 PM UTC
Updated: October 16, 2026 at 03:38 PM UTC
2 products affected across 2 vendorsRabbitmq ServerRabbitmq Server

Using rabbitmq-server by rabbitmq?

Get instant alerts when new vulnerabilities affect rabbitmq-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5, RabbitMQ OAuth credential refresh retains revoked runtime tags. when an existing AMQP connection refreshes from an OAuth token that grants the impersonator tag to a valid same-username token that no longer grants that tag, RabbitMQ updates the OAuth backend implementation (token/scopes/expiry) but leaves the connection's runtime #user.tags unchanged. rabbitaccesscontrol:checkuserid/2 then still honors the stale impersonator tag, so the connection (including newly opened channels) can continue publishing messages with a foreign AMQP userid after that privilege should have been revoked. A fresh connection using the downgraded token correctly refuses the same publish, proving the defect is stale session state rather than the token Limited to connections that once held impersonator and successfully refresh to a downgraded same-username rabbitauthbackendoauth2 (or an equivalent refresh-capable backend that returns tags) is enabled for This issue is fixed in versions 3.13.19, 4.0.24, 4.1.15, 4.2.10, and 4.3.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.13.0 ≤ v < 3.13.194.0.0 ≤ v < 4.0.244.1.0 ≤ v < 4.1.154.2.0 ≤ v < 4.2.104.3.0 ≤ v < 4.3.5
Affected range stops below 3.13.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

SSVC — Action Prioritization

SSVCPoCNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card