CVE-2026-67412

RabbitMQ: Federation upstream skips vhost authorization allowing cross-vhost message access

HIGH
7.1
CVSS Score
Published: September 25, 2026 at 04:20 PM UTC
Updated: October 8, 2026 at 04:44 PM UTC
2 products affected across 2 vendorsRabbitmq ServerRabbitmq Server

Using rabbitmq-server by rabbitmq?

Get instant alerts when new vulnerabilities affect rabbitmq-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.1
Exploit prediction
EPSS 0.3%
SSVC
PoC

Description

RabbitMQ is a messaging and streaming broker. From 3.13.0 until 4.3.3, 4.2.9 , 4.1.14, 4.0.24, and 3.13.18, Federation upstream in RabbitMQ skips vhost authorization allowing cross-vhost message access. what the bug lets you do. A policymaker on one vhost reads and drains messages out of another vhost it has no permission on. With the default ack-mode the source messages are consumed (deleted), not copied. Why that should not 1. Federation validates the upstream URI without any vhost-access Cross-vhost message read/drain from a per-vhost policymaker, breaking vhost tenancy This issue is fixed in versions 4.3.3, 4.2.9 , 4.1.14, 4.0.24, and 3.13.18.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.13.0 ≤ v < 3.13.184.0.0 ≤ v < 4.0.244.1.0 ≤ v < 4.1.144.2.0 ≤ v < 4.2.94.3.0 ≤ v < 4.3.3*
Affected range stops below 3.13.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.13.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_CONFIRMExploitVendor Advisory
Source: cverecord
https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-42pc-678q-v8qj
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9
x_refsource_MISCRelease Notes
Source: cverecord
https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-862

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card